Click or drag to resize

HiddenLineDrawing Class

Represents a hidden line drawing object. A hidden line drawing consists of curves generated from source objects. The curves correspond to edges, and silhouettes of source objects and intersections with cutting planes.
Inheritance Hierarchy
SystemObject
  Rhino.GeometryHiddenLineDrawing

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class HiddenLineDrawing : IDisposable

The HiddenLineDrawing type exposes the following members.

Properties
  NameDescription
Public propertyPoints
Point objects calculated by the hidden line drawing.
Public propertySegments
Sub-curve objects calculated by the hidden line drawing.
Public propertyViewport
Returns the ViewportInfo used by the hidden line drawing.
Public propertyWorldToHiddenLine
Returns the world-coordinate system to HLD-coordinate system transformation.
Top
Methods
  NameDescription
Public methodBoundingBox
Get tight bounding box of the hidden line drawing.
Public methodStatic memberCompute(HiddenLineDrawingParameters, Boolean)
Perform the hidden line drawing calculation based on input parameters
Public methodStatic memberCompute(HiddenLineDrawingParameters, Boolean, IProgressDouble, CancellationToken)
Perform the hidden line drawing calculation based on input parameters
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodRejoinCompatibleVisible
///
Join consecutive visible curves from a single FullCurve

Return Value

Type: 
true if successful, false otherwise.
Top
See Also