Click or drag to resize

SweepTwoRail Class

Utility class for generating Breps by sweeping cross section curves over two rail curves. Note, this class has been superseded by the Rhino.Geometry.Brep.CreateFromSweep static functions.
Inheritance Hierarchy
SystemObject
  Rhino.GeometrySweepTwoRail

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class SweepTwoRail

The SweepTwoRail type exposes the following members.

Constructors
  NameDescription
Public methodSweepTwoRail
Initializes a new instance of the SweepTwoRail class
Top
Properties
  NameDescription
Public propertyAngleToleranceRadians
Gets or sets the angle tolerance in radians.
Public propertyAutoAdjust
Set to true to have shape curves adjusted, sorted, and matched automatically. This will produce results comparable to Rhino's Sweep2 command. Set to false to not have shape curves adjusted, sorted, and matched automatically.
Public propertyClosedSweep
If the input rails are closed, ClosedSweep determines if the swept Breps will also be closed.
Public propertyMaintainHeight
Removes the association between the height scaling from the width scaling.
Public propertySweepTolerance
Gets or sets the sweeping tolerance.
Public propertyUseLegacySweeper
Set to true if you want to use the legacy, low-level sweeper found in earlier versions of Rhino.
Top
Methods
  NameDescription
Public methodPerformSweep(Curve, Curve, Curve)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.
Public methodPerformSweep(Curve, Curve, IEnumerableCurve)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.
Public methodPerformSweep(Curve, Curve, Curve, Double, Double)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.
Public methodPerformSweep(Curve, Curve, IEnumerableCurve, IEnumerableDouble, IEnumerableDouble)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.
Public methodPerformSweepRebuild(Curve, Curve, Curve, Int32)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.
Public methodPerformSweepRebuild(Curve, Curve, IEnumerableCurve, Int32)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.
Public methodPerformSweepRebuild(Curve, Curve, Curve, Double, Double, Int32)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.
Public methodPerformSweepRebuild(Curve, Curve, IEnumerableCurve, IEnumerableDouble, IEnumerableDouble, Int32)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.
Public methodPerformSweepRefit(Curve, Curve, Curve, Double)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.
Public methodPerformSweepRefit(Curve, Curve, IEnumerableCurve, Double)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.
Public methodPerformSweepRefit(Curve, Curve, Curve, Double, Double, Double)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.
Public methodPerformSweepRefit(Curve, Curve, IEnumerableCurve, IEnumerableDouble, IEnumerableDouble, Double)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.
Top
See Also