Click or drag to resize

SweepTwoRailPerformSweepRebuild Method (Curve, Curve, Curve, Double, Double, Int32)

Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Brep[] PerformSweepRebuild(
	Curve rail1,
	Curve rail2,
	Curve crossSection,
	double crossSectionParameterRail1,
	double crossSectionParameterRail2,
	int rebuildCount
)

Parameters

rail1
Type: Rhino.GeometryCurve
Rail to sweep shapes along.
rail2
Type: Rhino.GeometryCurve
Rail to sweep shapes along.
crossSection
Type: Rhino.GeometryCurve
Shape curve.
crossSectionParameterRail1
Type: SystemDouble
Curve parameter on first rail curve. Unused if is true.
crossSectionParameterRail2
Type: SystemDouble
Curve parameter on second rail curve. Unused if is true.
rebuildCount
Type: SystemInt32
Rebuild point count.

Return Value

Type: Brep
Array of Brep sweep results.
See Also