Click or drag to resize

SweepTwoRail Methods

The SweepTwoRail type exposes the following members.

Methods
  NameDescription
Public methodPerformSweep(Curve, Curve, Curve)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.
Public methodPerformSweep(Curve, Curve, IEnumerableCurve)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.
Public methodPerformSweep(Curve, Curve, Curve, Double, Double)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.
Public methodPerformSweep(Curve, Curve, IEnumerableCurve, IEnumerableDouble, IEnumerableDouble)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.
Public methodPerformSweepRebuild(Curve, Curve, Curve, Int32)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.
Public methodPerformSweepRebuild(Curve, Curve, IEnumerableCurve, Int32)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.
Public methodPerformSweepRebuild(Curve, Curve, Curve, Double, Double, Int32)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.
Public methodPerformSweepRebuild(Curve, Curve, IEnumerableCurve, IEnumerableDouble, IEnumerableDouble, Int32)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.
Public methodPerformSweepRefit(Curve, Curve, Curve, Double)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.
Public methodPerformSweepRefit(Curve, Curve, IEnumerableCurve, Double)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.
Public methodPerformSweepRefit(Curve, Curve, Curve, Double, Double, Double)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.
Public methodPerformSweepRefit(Curve, Curve, IEnumerableCurve, IEnumerableDouble, IEnumerableDouble, Double)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines a surface edge.
Top
See Also