Click or drag to resize

BrepTrim Class

Brep trim information is stored in BrepTrim classes. Brep.Trims is an array of all the trims in the brep. A BrepTrim is derived from CurveProxy so the trim can supply easy to use evaluation tools via the Curve virtual member functions. Note well that the domains and orientations of the curve m_C2[trim.m_c2i] and the trim as a curve may not agree.
Inheritance Hierarchy

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class BrepTrim : CurveProxy

The BrepTrim type exposes the following members.

Properties
  NameDescription
Public propertyBrep
Gets the Brep that owns this trim.
Public propertyEdge
Brep edge this trim belongs to. This will be null for singular trims
Public propertyEndVertex
BrepVertex at end of trim
Public propertyFace
Brep face this trim belongs to
Public propertyIsoStatus
Public propertyLoop
Loop that this trim belongs to
Public propertyStartVertex
BrepVertex at start of trim
Public propertyTrimCurve
Gets the Brep.Curves2D 2d curve geometry used by this trim, or null.
Public propertyTrimCurveIndex
Gets the Brep.Curves2D 2d curve index of the 2d curve geometry used by this trim, or -1.
Public propertyTrimIndex
Gets the index of this trim in the Brep.Trims collection.
Public propertyTrimType
Type of trim
Top
Methods
  NameDescription
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.
Public methodGetTolerances
The values in tolerance[] record the accuracy of the parameter space trimming curves.
Public methodGetTrimParameter
Get corresponding trim parameter at given edge parameter.
Public methodIsReversed
Get orientation of trim with respect to it's corresponding edge.
Public methodSetTolerances
The values in tolerance[] record the accuracy of the parameter space trimming curves.
Public methodSetTrimCurve(Int32)
Set 2d curve geometry used by a b-rep trim.
Public methodSetTrimCurve(Int32, Interval)
Set 2d curve geometry used by a b-rep trim.
Public methodSimplify
Returns a geometrically equivalent PolyCurve.

The PolyCurve has the following properties

1. All the PolyCurve segments are LineCurve, PolylineCurve, ArcCurve, or NurbsCurve.

2. The NURBS Curves segments do not have fully multiple interior knots.

3. Rational NURBS curves do not have constant weights.

4. Any segment for which IsLinear() or IsArc() is true is a Line, Polyline segment, or an Arc.

5. Adjacent co-linear or co-circular segments are combined.

6. Segments that meet with G1-continuity have there ends tuned up so that they meet with G1-continuity to within machine precision.
Top
See Also