BrepTrimSetTolerances Method |
Namespace: Rhino.Geometry
[Missing <param name="toleranceU"/> documentation for "M:Rhino.Geometry.BrepTrim.SetTolerances(System.Double,System.Double)"]
[Missing <param name="toleranceV"/> documentation for "M:Rhino.Geometry.BrepTrim.SetTolerances(System.Double,System.Double)"]
tolerance[0] = accuracy of parameter space curve in first ("u") parameter
tolerance[1] = accuracy of parameter space curve in second ("v") parameter
A value of RhinoMath.UnsetValue indicates that the tolerance should be computed. If the value >= 0.0, then the tolerance is set. If the value is RhinoMath.UnsetValue, then the tolerance needs to be computed.
If the trim is not singular, then the trim must have an edge. If P is a 3d point on the edge's curve and surface(u,v) = Q is the point on the surface that is closest to P, then there must be a parameter t in the interval [m_t[0], m_t[1]] such that |u - curve2d(t)[0]| <= tolerance[0] and |v - curve2d(t)[1]| <= tolerance[1] If P is the 3d point for the vertex brep.m_V[m_vi[k]] and (uk,vk) is the corresponding end of the trim's parameter space curve, then there must be a surface parameter (u,v) such that: