Click or drag to resize

BrepTrim Properties

The BrepTrim type exposes the following members.

Properties
  NameDescription
Public propertyBrep
Gets the Brep that owns this trim.
Public propertyEdge
Brep edge this trim belongs to. This will be null for singular trims
Public propertyEndVertex
BrepVertex at end of trim
Public propertyFace
Brep face this trim belongs to
Public propertyIsoStatus
Public propertyLoop
Loop that this trim belongs to
Public propertyStartVertex
BrepVertex at start of trim
Public propertyTrimCurve
Gets the Brep.Curves2D 2d curve geometry used by this trim, or null.
Public propertyTrimCurveIndex
Gets the Brep.Curves2D 2d curve index of the 2d curve geometry used by this trim, or -1.
Public propertyTrimIndex
Gets the index of this trim in the Brep.Trims collection.
Public propertyTrimType
Type of trim
Top
See Also