Click or drag to resize

Ray3d Structure

Represents an immutable ray in three dimensions, using position and direction.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public struct Ray3d : ISerializable, IEquatable<Ray3d>, 
	IEpsilonComparable<Ray3d>

The Ray3d type exposes the following members.

Constructors
  NameDescription
Public methodRay3d
Initializes a new Ray3d instance.
Top
Properties
  NameDescription
Public propertyDirection
Gets the direction vector of this ray.
Public propertyPosition
Gets the starting position of this ray.
Top
Methods
  NameDescription
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodEquals(Object)
Determines whether the specified System.Object is a Ray3d and has the same values as the present ray.
(Overrides ValueTypeEquals(Object).)
Public methodEquals(Ray3d)
Determines whether the specified Ray3d has the same value as the present ray.
Public methodGetHashCode
Computes a hashing number that represents the current ray.
(Overrides ValueTypeGetHashCode.)
Public methodPointAt
Evaluates a point along the ray.
Top
Operators
  NameDescription
Public operatorStatic memberEquality
Determines whether two Ray3d have equal values.
Public operatorStatic memberInequality
Determines whether two Ray3d have different values.
Top
See Also