Click or drag to resize

SpaceMorph Class

Represents a spacial, Euclidean morph.
Inheritance Hierarchy
SystemObject
  Rhino.GeometrySpaceMorph
    More...

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class SpaceMorph

The SpaceMorph type exposes the following members.

Constructors
  NameDescription
Protected methodSpaceMorph
Initializes a new instance of the SpaceMorph class
Top
Properties
  NameDescription
Public propertyPreserveStructure
true if the morph should be done in a way that preserves the structure of the geometry. In particular, for NURBS objects, true means that only the control points are moved. The PreserveStructure value does not affect the way meshes and points are morphed. The default is false.
Public propertyQuickPreview
true if the morph should be done as quickly as possible because the result is being used for some type of dynamic preview. If QuickPreview is true, the tolerance may be ignored. The QuickPreview value does not affect the way meshes and points are morphed. The default is false.
Public propertyTolerance
The desired accuracy of the morph. This value is primarily used for deforming surfaces and breps. The default is 0.0 and any value <= 0.0 is ignored by morphing functions. The Tolerance value does not affect the way meshes and points are morphed.
Top
Methods
  NameDescription
Public methodStatic memberIsMorphable
true if the geometry can be morphed by calling SpaceMorph.Morph(geometry)
Public methodMorph(GeometryBase)
Apply the space morph to geometry.
Public methodMorph(Plane)
Apply the space morph to a plane.
Public methodMorphPoint
Morphs an Euclidean point.

This method is abstract.

Top
See Also
Inheritance Hierarchy