Click or drag to resize

SporphSpaceMorph Class

Deforms an object from a source surface to a target surface.
Inheritance Hierarchy
SystemObject
  Rhino.GeometrySpaceMorph
    Rhino.Geometry.MorphsSporphSpaceMorph

Namespace:  Rhino.Geometry.Morphs
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class SporphSpaceMorph : SpaceMorph, 
	IDisposable

The SporphSpaceMorph type exposes the following members.

Constructors
  NameDescription
Public methodSporphSpaceMorph(Surface, Surface)
Constructs a Sporph space morph.
Public methodSporphSpaceMorph(Surface, Surface, Point2d, Point2d)
Constructs a Sporph space morph.
Top
Properties
  NameDescription
Public propertyConstrainNormal
Specifies how the normal direction of the base surface is mapped onto the target surface. To use the target surface normal, set to Unset.
Public propertyIsValid
Returns true if the space morph definition is valid, false otherwise.
Top
Methods
  NameDescription
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodMorphPoint
Morphs an Euclidean point.
(Overrides SpaceMorphMorphPoint(Point3d).)
Top
See Also