Click or drag to resize

Triangle3d Structure

Represents a triangle, modeled using double three points that use double-precision floating point numbers.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public struct Triangle3d

The Triangle3d type exposes the following members.

Constructors
  NameDescription
Public methodTriangle3d
Instantiates a new triangle.
Top
Properties
  NameDescription
Public propertyA
Gets the first triangle corner.
Public propertyAB
Gets the triangle edge connecting the A and B corners.
Public propertyAltitudeA
Gets the altitude line starting at corner A.
Public propertyAltitudeB
Gets the altitude line starting at corner B.
Public propertyAltitudeC
Gets the altitude line starting at corner C.
Public propertyAngleA
Gets the angle at the A corner.
Public propertyAngleB
Gets the angle at the B corner.
Public propertyAngleC
Gets the angle at the C corner.
Public propertyArea
Gets the area inside this triangle.
Public propertyAreaCenter
Gets the triangle area centroid.
Public propertyB
Gets the second triangle corner.
Public propertyBC
Gets the triangle edge connecting the B and C corners.
Public propertyBoundingBox
Gets the bounding box of this triangle.
Public propertyC
Gets the third triangle corner.
Public propertyCA
Gets the triangle edge connecting the C and A corners.
Public propertyCircumcenter
Gets the triangle circumcenter.
Public propertyCircumcircle
Gets the circumcircle of this triangle.
Public propertyMedianA
Gets the median line starting at corner A.
Public propertyMedianB
Gets the median line starting at corner B.
Public propertyMedianC
Gets the median line starting at corner C.
Public propertyOrthocenter
Gets the triangle orthocenter.
Public propertyPerimeter
Gets the perimeter of this triangle. This is the sum of the lengths of all edges.
Public propertyPerpendicularAB
Gets the perpendicular bisector for edge AB.
Public propertyPerpendicularBC
Gets the perpendicular bisector for edge BC.
Public propertyPerpendicularCA
Gets the perpendicular bisector for edge CA.
Top
Methods
  NameDescription
Public methodBarycentricCoordsAt
Gets the projection of a point onto the barycentric coordinates.
Public methodClosestParameterOnBoundary
Gets the parameter on the triangle boundary closest to a test point.
Public methodClosestPointOnBoundary
Gets the point on the triangle boundary closest to a test point.
Public methodPointAlongBoundary
Gets the point along the boundary of the triangle. The triangle boundary has a domain [0, 3] where each subsequent unit domain maps to a different edge.
Public methodPointAtBarycentricCoords
Gets a point within this triangle using barycentric coordinates.
Public methodPointOnInterior
Gets the point on the triangle using the AB and AC primary axes.
Public methodToMesh
Create a mesh from this triangle.
Public methodToPolyline
Create a polyline from this triangle.
Public methodTransform
Transform this triangle.
Public methodStatic memberTrySmallestEnclosingTriangle
Attempt to create the smallest triangle containing a set of planar points.
Public methodWithA
Replace the A corner.
Public methodWithB
Replace the B corner.
Public methodWithC
Replace the C corner.
Top
See Also