Click or drag to resize

Triangle3d Properties

The Triangle3d type exposes the following members.

Properties
  NameDescription
Public propertyA
Gets the first triangle corner.
Public propertyAB
Gets the triangle edge connecting the A and B corners.
Public propertyAltitudeA
Gets the altitude line starting at corner A.
Public propertyAltitudeB
Gets the altitude line starting at corner B.
Public propertyAltitudeC
Gets the altitude line starting at corner C.
Public propertyAngleA
Gets the angle at the A corner.
Public propertyAngleB
Gets the angle at the B corner.
Public propertyAngleC
Gets the angle at the C corner.
Public propertyArea
Gets the area inside this triangle.
Public propertyAreaCenter
Gets the triangle area centroid.
Public propertyB
Gets the second triangle corner.
Public propertyBC
Gets the triangle edge connecting the B and C corners.
Public propertyBoundingBox
Gets the bounding box of this triangle.
Public propertyC
Gets the third triangle corner.
Public propertyCA
Gets the triangle edge connecting the C and A corners.
Public propertyCircumcenter
Gets the triangle circumcenter.
Public propertyCircumcircle
Gets the circumcircle of this triangle.
Public propertyMedianA
Gets the median line starting at corner A.
Public propertyMedianB
Gets the median line starting at corner B.
Public propertyMedianC
Gets the median line starting at corner C.
Public propertyOrthocenter
Gets the triangle orthocenter.
Public propertyPerimeter
Gets the perimeter of this triangle. This is the sum of the lengths of all edges.
Public propertyPerpendicularAB
Gets the perpendicular bisector for edge AB.
Public propertyPerpendicularBC
Gets the perpendicular bisector for edge BC.
Public propertyPerpendicularCA
Gets the perpendicular bisector for edge CA.
Top
See Also