Click or drag to resize

Triangle3dPointAtBarycentricCoords Method

Gets a point within this triangle using barycentric coordinates.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 7.1
Syntax
public Point3d PointAtBarycentricCoords(
	Point2d coords
)

Parameters

coords
Type: Rhino.GeometryPoint2d
Barycentric mass for vertex B and C. A is valued as (1 - B - C).

Return Value

Type: Point3d
Point at barycentric mass.
See Also