Click or drag to resize

Triangle3d Methods

The Triangle3d type exposes the following members.

Methods
  NameDescription
Public methodBarycentricCoordsAt
Gets the projection of a point onto the barycentric coordinates.
Public methodClosestParameterOnBoundary
Gets the parameter on the triangle boundary closest to a test point.
Public methodClosestPointOnBoundary
Gets the point on the triangle boundary closest to a test point.
Public methodPointAlongBoundary
Gets the point along the boundary of the triangle. The triangle boundary has a domain [0, 3] where each subsequent unit domain maps to a different edge.
Public methodPointAtBarycentricCoords
Gets a point within this triangle using barycentric coordinates.
Public methodPointOnInterior
Gets the point on the triangle using the AB and AC primary axes.
Public methodToMesh
Create a mesh from this triangle.
Public methodToPolyline
Create a polyline from this triangle.
Public methodTransform
Transform this triangle.
Public methodStatic memberTrySmallestEnclosingTriangle
Attempt to create the smallest triangle containing a set of planar points.
Public methodWithA
Replace the A corner.
Public methodWithB
Replace the B corner.
Public methodWithC
Replace the C corner.
Top
See Also