Click or drag to resize

Point Class

Represents a geometric point.

This is fundamentally a class that derives from GeometryBase and contains a single Point3d location.

Inheritance Hierarchy

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public class Point : GeometryBase

The Point type exposes the following members.

Constructors
  NameDescription
Public methodPoint(Point3d)
Initializes a new point instance with a location.
Protected methodPoint(SerializationInfo, StreamingContext)
Protected constructor for internal use.
Top
Properties
  NameDescription
Public propertyLocation
Gets or sets the location (position) of this point.
Top
Methods
  NameDescription
Top
See Also