Click or drag to resize

SubDDisplayParametersDensity Enumeration

Density enumeration

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 7.18
Syntax
public enum Density
Members
  Member nameValueDescription
UnsetDensity0 Indicates the SubD display mesh density has not be set.
MinimumUserInterfaceDensity1 The minimum SubD display density that can be se in Rhino user interface is ExtraCoarseDensity (1).
MaximumUserInterfaceDensity5 The maximum SubD display density that can be se in Rhino user interface is ExtraFineDensity (5).
MinimumAdaptiveDensity1 SubD display density values <= MinimumAdaptiveDensity will never be adaptively reduced. SubD display density values > MinimumAdaptiveDensity may be adaptively reduced to a value >= MinimumAdaptiveDensity.
MinimumDensity0 Each SubD quad will generate 1 display mesh quads in a 1x1 grid. This density can only be used with SubDs where every face is a quad. User interface code never returns this density.
ExtraCoarseDensity1 When interpreted as an absolute SubD display density, each SubD quad will generate 4 display mesh quads in a 2x2 grid and each SubD N-gon will generate N display mesh quads. Adaptive reductions do not apply to this density. This is the minimum SubD display density.
CoarseDensity2 When interpreted as an absolute SubD display density, each SubD quad will generate 16 display mesh quads in a 4x4 grid and each SubD N-gon will generate N*4 display mesh quads. Adaptive reductions do not apply to this density.
MediumDensity3 When interpreted as an absolute SubD display density, each SubD quad will generate 64 display mesh quads in an 8x8 grid and each SubD N-gon will generate N*8 display mesh quads. When a SubD has more than 8000 faces, adaptive MediumDensity is reduced to CoarseDensity.
FineDensity4 When interpreted as an absolute SubD display density, each SubD quad will generate 256 display mesh quads in a 16x16 grid and each SubD N-gon will generate N*16 display mesh quads. When a SubD has more than 2000 faces, adaptive FineDensity is reduced to adaptive MediumDensity.
DefaultDensity4 When interpreted as an absolute SubD display density, each SubD quad will generate 256 display mesh quads in a 16x16 grid and each SubD N-gon will generate N*16 display mesh quads. When a SubD has more than 2000 faces, adaptive DefaultDensity is reduced to adaptive MediumDensity. This is the default value for creating mesh approximations of SubD surface. When treadted as an adaptive setting, it produces acceptable results for most SubDs.
ExtraFineDensity5 When interpreted as an absolute SubD display density, each SubD quad will generate 1024 display mesh quads in a 32x32 grid and each SubD N-gon will generate N*32 display mesh quads. When a SubD has more than 500 faces, adaptive ExtraFineDensity is reduced to adaptive FineDensity.
MaximumDensity6 When interpreted as an absolute SubD display density, each SubD quad will generate 4096 display mesh quads in a 64x64 grid and each SubD N-gon will generate N*64 display mesh quads. SubDDisplayParameters.AdaptiveDensity() determines if the subd display density is treated adaptively or absolutely. This value creates ridiculously dense display meshes and should generally be avoided. No Rhino user interface will create this value.
See Also