Click or drag to resize

Point4d Structure

Represents the four coordinates of a point in four-dimensional space.

The W (fourth) dimension is often considered the weight of the point as seen in 3D space.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public struct Point4d : ISerializable, IEquatable<Point4d>, 
	IEpsilonComparable<Point4d>, IFormattable

The Point4d type exposes the following members.

Constructors
  NameDescription
Public methodPoint4d(Point3d)
Initializes a new instance of the Point4d class from the coordinates of a point.
Public methodPoint4d(Point4d)
Initializes a new point by copying coordinates from another point.
Public methodPoint4d(Double, Double, Double, Double)
Initializes a new instance of the Point4d class based on coordinates.
Top
Properties
  NameDescription
Public propertyIsValid
Returns an indication regarding the validity of this point.
Public propertyStatic memberUnset
Gets the value of a point with all coordinates set as RhinoMath.UnsetValue.
Public propertyW
Gets or sets the W (fourth) coordinate -or weight- of this point.
Public propertyX
Gets or sets the X (first) coordinate of this point.
Public propertyY
Gets or sets the Y (second) coordinate of this point.
Public propertyZ
Gets or sets the Z (third) coordinate of this point.
Top
Methods
  NameDescription
Public methodStatic memberAdd
Sums two Point4d together.

(Provided for languages that do not support operator overloading. You can use the + operator otherwise)

Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodEquals(Object)
Determines whether the specified System.Object is Point4d and has same coordinates as the present point.
(Overrides ValueTypeEquals(Object).)
Public methodEquals(Point4d)
Determines whether the specified point has same value as the present point.
Public methodGetHashCode
Computes the hash code for the present point.
(Overrides ValueTypeGetHashCode.)
Public methodStatic memberMultiply
Multiplies a point by a number.

(Provided for languages that do not support operator overloading. You can use the * operator otherwise)

Public methodStatic memberSubtract
Subtracts the second point from the first point.

(Provided for languages that do not support operator overloading. You can use the - operator otherwise)

Public methodToString
Returns the fully qualified type name of this instance.
(Overrides ValueTypeToString.)
Public methodToString(String, IFormatProvider)
Formats the value of the current instance using the specified format.
Public methodTransform
Transforms the present point in place. The transformation matrix acts on the left of the point. i.e.,

result = transformation*point

Top
Operators
  NameDescription
Public operatorStatic memberAddition
Sums two Point4d together.
Public operatorStatic memberEquality
Determines whether two Point4d have equal values.
Public operatorStatic memberInequality
Determines whether two Point4d have different values.
Public operatorStatic memberMultiply(Point4d, Point4d)
Multiplies two Point4d together, returning the dot (internal) product of the two. This is not the cross product.
Public operatorStatic memberMultiply(Point4d, Double)
Multiplies a point by a number.
Public operatorStatic memberSubtraction
Subtracts the second point from the first point.
Top
See Also