Click or drag to resize

Point4d Methods

The Point4d type exposes the following members.

Methods
  NameDescription
Public methodStatic memberAdd
Sums two Point4d together.

(Provided for languages that do not support operator overloading. You can use the + operator otherwise)

Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodEquals(Object)
Determines whether the specified System.Object is Point4d and has same coordinates as the present point.
(Overrides ValueTypeEquals(Object).)
Public methodEquals(Point4d)
Determines whether the specified point has same value as the present point.
Public methodGetHashCode
Computes the hash code for the present point.
(Overrides ValueTypeGetHashCode.)
Public methodStatic memberMultiply
Multiplies a point by a number.

(Provided for languages that do not support operator overloading. You can use the * operator otherwise)

Public methodStatic memberSubtract
Subtracts the second point from the first point.

(Provided for languages that do not support operator overloading. You can use the - operator otherwise)

Public methodToString
Returns the fully qualified type name of this instance.
(Overrides ValueTypeToString.)
Public methodToString(String, IFormatProvider)
Formats the value of the current instance using the specified format.
Public methodTransform
Transforms the present point in place. The transformation matrix acts on the left of the point. i.e.,

result = transformation*point

Top
See Also