Click or drag to resize

ObjectTable Class

[Missing <summary> documentation for "T:Rhino.DocObjects.Tables.ObjectTable"]

Inheritance Hierarchy
SystemObject
  Rhino.FileIOCommonComponentTableRhinoObject
    Rhino.DocObjects.TablesRhinoDocCommonTableRhinoObject
      Rhino.DocObjects.TablesObjectTable

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class ObjectTable : RhinoDocCommonTable<RhinoObject>, 
	ICollection<RhinoObject>, IEnumerable<RhinoObject>, IEnumerable

The ObjectTable type exposes the following members.

Properties
  NameDescription
Public propertyBoundingBox
Gets the bounding box for all objects (normal, locked and hidden) in this document that exist in "model" space. This bounding box does not include objects that exist in layout space.
Public propertyBoundingBoxVisible
Gets the bounding box for all visible objects (normal and locked) in this document that exist in "model" space. This bounding box does not include hidden objects or any objects that exist in layout space.
Public propertyComponentType (Overrides CommonComponentTableTComponentType.)
Public propertyDocument
Gets the document that owns this object table.
Public propertyHistoryRecordCount
Returns the amount of history records in this document.
Top
Methods
  NameDescription
Public methodAdd(GeometryBase)
Adds geometry that is not further specified.

This is meant, for example, to handle addition of sets of different geometrical entities.

Public methodAdd(GeometryBase, ObjectAttributes)
Adds geometry that is not further specified.

This is meant, for example, to handle addition of sets of different geometrical entities.

Public methodAdd(GeometryBase, ObjectAttributes, HistoryRecord, Boolean)
Adds geometry that is not further specified.

This is meant, for example, to handle addition of sets of different geometrical entities.

Public methodAddAngularDimension(AngularDimension)
Adds a angular dimension object to the document.
Public methodAddAngularDimension(AngularDimension, ObjectAttributes)
Adds a angular dimension object to the document.
Public methodAddAngularDimension(AngularDimension, ObjectAttributes, HistoryRecord, Boolean)
Adds an angular dimension object to the document.
Public methodAddArc(Arc)
Adds a curve object to the document representing an arc.
Public methodAddArc(Arc, ObjectAttributes)
Adds a curve object to the document representing an arc.
Public methodAddArc(Arc, ObjectAttributes, HistoryRecord, Boolean)
Public methodAddBox(Box)
Adds a box to the object table.
Public methodAddBox(Box, ObjectAttributes)
Adds a box to the object table.
Public methodAddBox(Box, ObjectAttributes, HistoryRecord, Boolean)
Adds a box to the object table, as an extrusion.
Public methodCode exampleAddBrep(Brep)
Adds a brep object to Rhino.
Public methodAddBrep(Brep, ObjectAttributes)
Adds a brep object to Rhino.
Public methodAddBrep(Brep, ObjectAttributes, HistoryRecord, Boolean)
Public methodAddBrep(Brep, ObjectAttributes, HistoryRecord, Boolean, Boolean)
Public methodAddCentermark
Adds an ordinate dimension object to the document.
Public methodCode exampleAddCircle(Circle)
Adds a curve object to the document representing a circle.
Public methodAddCircle(Circle, ObjectAttributes)
Adds a curve object to the document representing a circle.
Public methodAddCircle(Circle, ObjectAttributes, HistoryRecord, Boolean)
Public methodAddClippingPlane(Plane, Double, Double, IEnumerableGuid)
Adds a clipping plane object to Rhino.
Public methodCode exampleAddClippingPlane(Plane, Double, Double, Guid)
Adds a clipping plane object to Rhino.
Public methodAddClippingPlane(Plane, Double, Double, IEnumerableGuid, ObjectAttributes)
Adds a clipping plane object to Rhino.
Public methodAddClippingPlane(Plane, Double, Double, IEnumerableGuid, ObjectAttributes, HistoryRecord, Boolean)
Public methodAddClippingPlane(Plane, Double, Double, Guid, ObjectAttributes, HistoryRecord, Boolean)
Public methodCode exampleAddCurve(Curve)
Adds a curve object to Rhino.
Public methodAddCurve(Curve, ObjectAttributes)
Adds a curve object to Rhino.
Public methodAddCurve(Curve, ObjectAttributes, HistoryRecord, Boolean)
Public methodAddEllipse(Ellipse)
Adds a curve object to the document representing an ellipse.
Public methodAddEllipse(Ellipse, ObjectAttributes)
Adds a curve object to the document representing an ellipse.
Public methodAddEllipse(Ellipse, ObjectAttributes, HistoryRecord, Boolean)
Public methodAddExplodedInstancePieces
Public methodAddExtrusion(Extrusion)
Adds an extrusion object to Rhino.
Public methodAddExtrusion(Extrusion, ObjectAttributes)
Adds an extrusion object to Rhino.
Public methodAddExtrusion(Extrusion, ObjectAttributes, HistoryRecord, Boolean)
Public methodCode exampleAddHatch(Hatch)
Public methodAddHatch(Hatch, ObjectAttributes)
Public methodAddHatch(Hatch, ObjectAttributes, HistoryRecord, Boolean)
Public methodAddInstanceObject(Int32, Transform)
Adds an instance object to the document.
Public methodAddInstanceObject(Int32, Transform, ObjectAttributes)
Adds an instance object to the document.
Public methodAddInstanceObject(Int32, Transform, ObjectAttributes, HistoryRecord, Boolean)
Adds an instance object to the document.
Public methodAddLeader(IEnumerablePoint3d)
Public methodAddLeader(Leader)
Adds a Leader object to the document.
Public methodAddLeader(Leader, ObjectAttributes)
Adds Leader object to the document.
Public methodCode exampleAddLeader(Plane, IEnumerablePoint2d)
Public methodAddLeader(String, IEnumerablePoint3d)
Public methodAddLeader(Plane, IEnumerablePoint2d, ObjectAttributes)
Public methodAddLeader(String, Plane, IEnumerablePoint2d)
Public methodAddLeader(Leader, ObjectAttributes, HistoryRecord, Boolean)
Adds a Leader object to the document.
Public methodAddLeader(String, Plane, IEnumerablePoint2d, ObjectAttributes)
Public methodAddLeader(String, Plane, IEnumerablePoint2d, ObjectAttributes, HistoryRecord, Boolean)
Public methodAddLine(Line)
Adds a line object to Rhino.
Public methodAddLine(Line, ObjectAttributes)
Adds a line object to Rhino.
Public methodCode exampleAddLine(Point3d, Point3d)
Adds a line object to Rhino.
Public methodAddLine(Point3d, Point3d, ObjectAttributes)
Adds a line object to Rhino.
Public methodAddLine(Point3d, Point3d, ObjectAttributes, HistoryRecord, Boolean)
Public methodCode exampleAddLinearDimension(LinearDimension)
Adds a linear dimension object to the document.
Public methodAddLinearDimension(LinearDimension, ObjectAttributes)
Adds a linear dimension object to the document.
Public methodAddLinearDimension(LinearDimension, ObjectAttributes, HistoryRecord, Boolean)
Adds a linear dimension object to the document.
Public methodCode exampleAddMesh(Mesh)
Adds a mesh object to Rhino.
Public methodAddMesh(Mesh, ObjectAttributes)
Adds a mesh object to Rhino.
Public methodAddMesh(Mesh, ObjectAttributes, HistoryRecord, Boolean)
Public methodAddMesh(Mesh, ObjectAttributes, HistoryRecord, Boolean, Boolean)
Public methodAddMorphControl(MorphControl)
Public methodAddMorphControl(MorphControl, ObjectAttributes)
Public methodAddMorphControl(MorphControl, ObjectAttributes, HistoryRecord, Boolean)
Public methodAddOrderedPointCloud
Adds a point cloud object to the document.
Public methodAddOrdinateDimension
Adds an ordinate dimension object to the document.
Public methodAddPictureFrame
Creates a PictureFrame object from a plane and a path to an image file, Note, a PictureFrame object is just a Plane surface or mesh that has a material with a texture assigned to it that displays in all display modes.
Public methodCode exampleAddPoint(Point3d)
Adds a point object to the document.
Public methodCode exampleAddPoint(Point3f)
Adds a point object to the document.
Public methodAddPoint(Point3d, ObjectAttributes)
Adds a point object to the document.
Public methodAddPoint(Point3f, ObjectAttributes)
Adds a point object to the document.
Public methodAddPoint(Double, Double, Double)
Adds a point object to the document.
Public methodAddPoint(Point, ObjectAttributes, HistoryRecord, Boolean)
Adds a point object and its geometry-linked information to the document
Public methodAddPoint(Point3d, ObjectAttributes, HistoryRecord, Boolean)
Adds a point object to the document
Public methodAddPointCloud(IEnumerablePoint3d)
Adds a point cloud object to the document.
Public methodAddPointCloud(PointCloud)
Adds a point cloud object to the document.
Public methodAddPointCloud(IEnumerablePoint3d, ObjectAttributes)
Adds a point cloud object to the document.
Public methodAddPointCloud(PointCloud, ObjectAttributes)
Adds a point cloud object to the document.
Public methodAddPointCloud(IEnumerablePoint3d, ObjectAttributes, HistoryRecord, Boolean)
Adds a point cloud object to the document.
Public methodAddPointCloud(PointCloud, ObjectAttributes, HistoryRecord, Boolean)
Adds a point cloud object to the document.
Public methodAddPoints(IEnumerablePoint3d)
Adds multiple points to the document.
Public methodAddPoints(IEnumerablePoint3f)
Adds multiple points to the document.
Public methodAddPoints(IEnumerablePoint3d, ObjectAttributes)
Adds multiple points to the document.
Public methodAddPoints(IEnumerablePoint3f, ObjectAttributes)
Adds multiple points to the document.
Public methodCode exampleAddPolyline(IEnumerablePoint3d)
Adds a polyline object to Rhino.
Public methodAddPolyline(IEnumerablePoint3d, ObjectAttributes)
Adds a polyline object to Rhino.
Public methodAddPolyline(IEnumerablePoint3d, ObjectAttributes, HistoryRecord, Boolean)
Public methodCode exampleAddRadialDimension(RadialDimension)
Public methodAddRadialDimension(RadialDimension, ObjectAttributes)
Public methodAddRadialDimension(RadialDimension, ObjectAttributes, HistoryRecord, Boolean)
Adds a radial dimension object to the document.
Public methodAddRectangle(Rectangle3d)
Adds a rectangle to the object table.
Public methodAddRectangle(Rectangle3d, ObjectAttributes)
Adds a rectangle to the object table.
Public methodAddRectangle(Rectangle3d, ObjectAttributes, HistoryRecord, Boolean)
Adds a rectangle to the object table.
Public methodAddRhinoObject(CustomBrepObject)
Public methodAddRhinoObject(CustomMeshObject)
Public methodAddRhinoObject(CustomPointObject)
Public methodAddRhinoObject(BrepObject, Brep)
Public methodAddRhinoObject(CurveObject, Curve)
Public methodAddRhinoObject(CustomBrepObject, HistoryRecord)
Public methodAddRhinoObject(CustomCurveObject, HistoryRecord)
Public methodAddRhinoObject(CustomMeshObject, HistoryRecord)
Public methodAddRhinoObject(CustomPointObject, HistoryRecord)
Public methodAddRhinoObject(MeshObject, Mesh)
Public methodAddRhinoObject(PointObject, Point)
Public methodCode exampleAddSphere(Sphere)
Public methodAddSphere(Sphere, ObjectAttributes)
Public methodAddSphere(Sphere, ObjectAttributes, HistoryRecord, Boolean)
Public methodAddSubD(SubD)
Adds a SubD object to Rhino.
Public methodAddSubD(SubD, ObjectAttributes)
Adds a SubD object to Rhino.
Public methodAddSubD(SubD, ObjectAttributes, HistoryRecord, Boolean)
Adds a SubD object to Rhino.
Public methodCode exampleAddSurface(Surface)
Adds a surface object to Rhino.
Public methodAddSurface(Surface, ObjectAttributes)
Adds a surface object to Rhino.
Public methodAddSurface(Surface, ObjectAttributes, HistoryRecord, Boolean)
Public methodCode exampleAddText(Text3d)
Adds an annotation text object to the document.
Public methodAddText(TextEntity)
Adds a v6_TextObject to the document.
Public methodAddText(Text3d, ObjectAttributes)
Adds an annotation text object to the document.
Public methodAddText(TextEntity, ObjectAttributes)
Adds a text object to the document.
Public methodAddText(TextEntity, ObjectAttributes, HistoryRecord, Boolean)
Adds a text object to the document.
Public methodCode exampleAddText(String, Plane, Double, String, Boolean, Boolean)
Adds an annotation text object to the document.
Public methodAddText(String, Plane, Double, String, Boolean, Boolean, ObjectAttributes)
Adds an annotation text object to the document.
Public methodAddText(String, Plane, Double, String, Boolean, Boolean, TextJustification)
Public methodAddText(String, Plane, Double, String, Boolean, Boolean, TextJustification, ObjectAttributes)
Public methodAddText(String, Plane, Double, String, Boolean, Boolean, ObjectAttributes, HistoryRecord, Boolean)
Public methodAddText(String, Plane, Double, String, Boolean, Boolean, TextJustification, ObjectAttributes, HistoryRecord, Boolean)
Public methodAddTextDot(TextDot)
Adds a text dot object to Rhino.
Public methodAddTextDot(String, Point3d)
Adds a text dot object to Rhino.
Public methodAddTextDot(TextDot, ObjectAttributes)
Adds a text dot object to Rhino.
Public methodAddTextDot(String, Point3d, ObjectAttributes)
Adds a text dot object to Rhino.
Public methodAddTextDot(TextDot, ObjectAttributes, HistoryRecord, Boolean)
Public methodAllObjectsSince
Gets all the objects that have been added to the document since a given runtime serial number.
Public methodDelete(RhinoObject)
Deletes an object, taking into account modes and not showing error message boxes.
(Overrides CommonComponentTableTDelete(T).)
Public methodDelete(Guid, Boolean)
Deletes object from document. The deletion can be undone by calling UndeleteObject().
Public methodDelete(IEnumerableGuid, Boolean)
Deletes a collection of objects from the document.
Public methodDelete(ObjRef, Boolean)
Deletes objref.Object(). The deletion can be undone by calling UndeleteObject().
Public methodDelete(RhinoObject, Boolean)
Deletes object from document. The deletion can be undone by calling UndeleteObject().
Public methodDelete(ObjRef, Boolean, Boolean)
Deletes objref.Object(). The deletion can be undone by calling UndeleteObject().
Public methodDelete(RhinoObject, Boolean, Boolean)
Deletes object from document. The deletion can be undone by calling UndeleteObject().
Public methodDeleteGrip(GripObject)
Deletes a grip object.
Public methodDeleteGrip(Guid)
Deletes a grip object.
Public methodDeleteGrip(ObjRef)
Deletes a grip object.
Public methodDeleteGrips(IEnumerableGripObject)
Deletes one or more grip objects.
Public methodDeleteGrips(IEnumerableObjRef)
Deletes one or more grip objects.
Public methodDeleteGrips(IEnumerableGuid)
Deletes one or more grip objects.
Public methodDeleteGrips(RhinoObject, IEnumerableInt32)
Deletes one or more grip objects.
Public methodDuplicate(Guid)
Same as TransformObject(objref, ON_Xform.Identity, false)
Public methodDuplicate(ObjRef)
Duplicates the object that is referenced by objref.

Same as Transform(objref, Transform.Identity, false)

Public methodDuplicate(RhinoObject)
Duplicates the object that is referenced by obj.

Same as TransformObject(obj, Transform.Identityy, false)

Public methodFind
Use the object runtime serial number to find a rhino object in the document. This is the value stored on RhinoObject.RuntimeObjectSerialNumber. The RhinoObject constructor sets the runtime serial number and every instance of a RhinoObject class will have a unique serial number for the duration of the Rhino application. If an object is replaced with a new object, then the new object will have a different runtime serial number. Deleted objects stored in the undo list maintain their runtime serial numbers and this function will return pointers to these objects. Call RhinoObject.IsDeleted if you need to determine if the returned object is active or deleted. The runtime serial number is not saved in files.
Public methodFindByCrossingWindowRegion(RhinoViewport, IEnumerablePoint3d, Boolean, ObjectType)
Finds objects bounded by a polyline region
Public methodFindByCrossingWindowRegion(RhinoViewport, Point2d, Point2d, Boolean, ObjectType)
Finds objects bounded by a region
Public methodFindByDrawColor
Finds all objects whose draw color matches a given color.
Public methodFindByFilter
Same as GetObjectList but converts the result to an array.
Public methodFindByGroup
Finds all RhinoObjects that are in a given group.
Public methodFindByLayer(Layer)
Finds all RhinoObjects that are in a given layer.
Public methodCode exampleFindByLayer(String)
Finds all RhinoObjects that are in a given layer.
Public methodFindByObjectType
Public methodFindByUserString(String, String, Boolean)
Finds all objects whose UserString matches the search patterns.
Public methodFindByUserString(String, String, Boolean, Boolean, Boolean, ObjectEnumeratorSettings)
Finds all objects whose UserString matches the search patterns.
Public methodFindByUserString(String, String, Boolean, Boolean, Boolean, ObjectType)
Finds all objects whose UserString matches the search patterns.
Public methodFindByWindowRegion(RhinoViewport, IEnumerablePoint3d, Boolean, ObjectType)
Finds objects bounded by a polyline region
Public methodFindByWindowRegion(RhinoViewport, Point2d, Point2d, Boolean, ObjectType)
Finds objects bounded by a polyline region
Public methodFindClippingPlanesForViewport
Finds all of the clipping plane objects that actively clip a viewport.
Public methodFindGeometry
Same as FindId, but returns the Geometry property directly, if it exists.
Public methodFindId

Uses the object guid to find a rhino object. Deleted objects cannot be found by id. The guid is the value that is stored on RhinoObject.Id

In a single document, no two active objects have the same guid. If an object is replaced with a new object, then the guid persists. For example, if the _Move command moves an object, then the moved object inherits it's guid from the starting object. If the Copy command copies an object, then the copy gets a new guid. This guid persists through file saving/opening operations. This function will not find grip objects.
(Overrides CommonComponentTableTFindId(Guid).)
Public methodGetEnumerator (Overrides CommonComponentTableTGetEnumerator.)
Public methodGetObjectList(ObjectEnumeratorSettings)
Returns an enumerable based on a ObjectEnumeratorSettings filter.
Public methodGetObjectList(ObjectType)
Public methodCode exampleGetObjectList(Type)
Public methodGetObjectsByTypeT
Returns Rhino object by type.
Public methodGetObjectsByTypeT(ObjectEnumeratorSettings)
Returns Rhino object by type.
Public methodGetSelectedObjects
Public methodGetSelectedObjectTypes
Public methodGripUpdate
Altered grip positions on a RhinoObject are used to calculate an updated object that is added to the document.
Public methodHide(Guid, Boolean)
If Object().IsNormal() is true, then the object will be hidden.
Public methodHide(ObjRef, Boolean)
If objref.Object().IsNormal() is true, then the object will be hidden.
Public methodHide(RhinoObject, Boolean)
If obj.IsNormal() is true, then the object will be hidden.
Public methodLock(Guid, Boolean)
If objref.Object().IsNormal() is true, then the object will be locked.
Public methodLock(ObjRef, Boolean)
If objref.Object().IsNormal() is true, then the object will be locked.
Public methodLock(RhinoObject, Boolean)
If obj.IsNormal() is true, then the object will be locked.
Public methodModifyAttributes(Guid, ObjectAttributes, Boolean)
Modifies an object's attributes. Cannot be used to change object id.
Public methodModifyAttributes(ObjRef, ObjectAttributes, Boolean)
Modifies an object's attributes. Cannot be used to change object id.
Public methodModifyAttributes(RhinoObject, ObjectAttributes, Boolean)
Modifies an object's attributes. Cannot be used to change object id.
Public methodModifyRenderMaterial(Guid, RenderMaterial)
Modifies an object's render material assignment, this will set the objects material source to ObjectMaterialSource.MaterialFromObject.
Public methodModifyRenderMaterial(ObjRef, RenderMaterial)
Modifies an object's render material assignment, this will set the objects material source to ObjectMaterialSource.MaterialFromObject.
Public methodModifyRenderMaterial(RhinoObject, RenderMaterial)
Modifies an object's render material assignment, this will set the objects material source to ObjectMaterialSource.MaterialFromObject.
Public methodModifyTextureMapping(Guid, Int32, TextureMapping)
Public methodModifyTextureMapping(ObjRef, Int32, TextureMapping)
Public methodModifyTextureMapping(RhinoObject, Int32, TextureMapping)
Public methodMostRecentObject
Gets the most recently added object that is still in the Document.
Public methodObjectCount
Returns the number objects that pass a filter.
Public methodPickObjects
Pick one or more objects based on a given pick context
Public methodPurge(RhinoObject)
Removes object from document and deletes the pointer. Typically you will want to call Delete instead in order to keep the object on the undo list.
Public methodPurge(UInt32)
Removes object from document and deletes the pointer. Typically you will want to call Delete instead in order to keep the object on the undo list.
Public methodReplace(Guid, Arc)
Replaces one object with new curve object.
Public methodReplace(Guid, Brep)
Replaces one object with new brep object.
Public methodReplace(Guid, Circle)
Replaces one object with new curve object.
Public methodReplace(Guid, Curve)
Replaces one object with new curve object.
Public methodReplace(Guid, Extrusion)
Replaces one object with new extrusion object.
Public methodReplace(Guid, Hatch)
Replaces one object with new hatch object.
Public methodReplace(Guid, Leader)
Replaces one object with new text object.
Public methodReplace(Guid, Line)
Replaces one object with new line curve object.
Public methodReplace(Guid, Mesh)
Replaces one object with new mesh object.
Public methodReplace(Guid, Point)
Replaces one object with new point object.
Public methodReplace(Guid, Point3d)
Replaces one object with new point object.
Public methodReplace(Guid, PointCloud)
Replaces one object with new point cloud object.
Public methodReplace(Guid, Polyline)
Replaces one object with new curve object.
Public methodReplace(Guid, SubD)
Replaces one object with new subd object.
Public methodReplace(Guid, Surface)
Replaces one object with new surface object.
Public methodReplace(Guid, TextDot)
Replaces one object with new text dot object.
Public methodReplace(Guid, TextEntity)
Replaces one object with new text object.
Public methodReplace(ObjRef, RhinoObject)
Replaces one object with another. Conceptually, this function is the same as calling Setting new_object attributes = old_object attributes DeleteObject(old_object); AddObject(old_object);
Public methodReplace(ObjRef, Arc)
Replaces one object with new curve object.
Public methodReplace(ObjRef, Brep)
Replaces one object with new brep object.
Public methodReplace(ObjRef, Circle)
Replaces one object with new curve object.
Public methodCode exampleReplace(ObjRef, Curve)
Replaces one object with new curve object.
Public methodReplace(ObjRef, Extrusion)
Replaces one object with new extrusion object.
Public methodReplace(ObjRef, Hatch)
Replaces one object with new hatch object.
Public methodReplace(ObjRef, Leader)
Replaces one object with new text object.
Public methodReplace(ObjRef, Line)
Replaces one object with new line curve object.
Public methodReplace(ObjRef, Mesh)
Replaces one object with new mesh object.
Public methodReplace(ObjRef, Point)
Replaces one object with new point object.
Public methodReplace(ObjRef, Point3d)
Replaces one object with new point object.
Public methodReplace(ObjRef, PointCloud)
Replaces one object with new point cloud object.
Public methodReplace(ObjRef, Polyline)
Replaces one object with new curve object.
Public methodReplace(ObjRef, SubD)
Replaces one object with a new SubD object.
Public methodReplace(ObjRef, Surface)
Replaces one object with new surface object.
Public methodReplace(ObjRef, TextDot)
Replaces one object with new text dot object.
Public methodReplace(ObjRef, TextEntity)
Replaces one object with new text object.
Public methodReplace(Guid, Brep, Boolean)
Public methodReplace(Guid, GeometryBase, Boolean)
Replaces the geometry in one object.
Public methodReplace(ObjRef, Brep, Boolean)
Public methodReplace(ObjRef, GeometryBase, Boolean)
Replaces the geometry in one object.
Public methodReplaceInstanceObject(Guid, Int32)
Replaces the underlying instance definition of an instance object.
Public methodReplaceInstanceObject(ObjRef, Int32)
Replaces the underlying instance definition of an instance object.
Public methodCode exampleSelect(Guid)
Select a single object.
Public methodSelect(IEnumerableObjRef)
Selects a collection of objects.
Public methodCode exampleSelect(IEnumerableGuid)
Selects a collection of objects.
Public methodSelect(ObjRef)
Select a single object.
Public methodSelect(Guid, Boolean)
Select or deselects a single object.
Public methodSelect(IEnumerableObjRef, Boolean)
Selects or deselects a collection of objects.
Public methodSelect(IEnumerableGuid, Boolean)
Selects or deselects a collection of objects.
Public methodSelect(ObjRef, Boolean)
Select or deselects a single object.
Public methodSelect(Guid, Boolean, Boolean)
Select or deselects a single object.
Public methodSelect(ObjRef, Boolean, Boolean)
Select or deselects a single object.
Public methodSelect(Guid, Boolean, Boolean, Boolean)
Select or deselects a single object.
Public methodSelect(ObjRef, Boolean, Boolean, Boolean)
Select or deselects a single object.
Public methodSelect(Guid, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)
Select or deselects a single object.
Public methodSelect(ObjRef, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)
Select or deselects a single object.
Public methodShow(Guid, Boolean)
If Object().IsHidden() is true, then the object will be returned to normal (visible and selectable) mode.
Public methodShow(ObjRef, Boolean)
If objref.Object().IsHidden() is true, then the object will be returned to normal (visible and selectable) mode.
Public methodShow(RhinoObject, Boolean)
If obj.IsHidden() is true, then the object will be returned to normal (visible and selectable) mode.
Public methodTransform(Guid, Transform, Boolean)
Constructs a new object that is the transformation of the existing object and deletes the existing object if deleteOriginal is true.
Public methodCode exampleTransform(ObjRef, Transform, Boolean)
Constructs a new object that is the transformation of the existing object and deletes the existing object if deleteOriginal is true.
Public methodTransform(RhinoObject, Transform, Boolean)
Constructs a new object that is the transformation of the existing object and deletes the existing object if deleteOriginal is true.
Public methodTransformWithHistory(Guid, Transform)
Constructs a new object that is the transformation of the existing object and records history of the transformation if history recording is turned on. If history recording is not enabled, this function will act the same as Transform(objectId, xform, false)
Public methodTransformWithHistory(ObjRef, Transform)
Constructs a new object that is the transformation of the existing object and records history of the transformation if history recording is turned on. If history recording is not enabled, this function will act the same as Transform(objref, xform, false)
Public methodTransformWithHistory(RhinoObject, Transform)
Constructs a new object that is the transformation of the existing object and records history of the transformation if history recording is turned on. If history recording is not enabled, this function will act the same as Transform(obj, xform, false)
Public methodTryFindPoint
Finds the location of a point, if a point exists in the document.
Public methodUndelete(RhinoObject)
Public methodUndelete(UInt32)
Public methodUnlock(Guid, Boolean)
If Object().IsLocked() is true, then the object will be returned to normal (visible and selectable) mode.
Public methodUnlock(ObjRef, Boolean)
If objref.Object().IsLocked() is true, then the object will be returned to normal (visible and selectable) mode.
Public methodUnlock(RhinoObject, Boolean)
If obj.IsLocked() is true, then the object will be returned to normal (visible and selectable) mode.
Public methodCode exampleUnselectAll
Unselect objects.
Public methodUnselectAll(Boolean)
Unselect objects.
Top
See Also