Click or drag to resize

ObjectTableLock Method (ObjRef, Boolean)

If objref.Object().IsNormal() is true, then the object will be locked.

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool Lock(
	ObjRef objref,
	bool ignoreLayerMode
)

Parameters

objref
Type: Rhino.DocObjectsObjRef
reference to normal object to lock.
ignoreLayerMode
Type: SystemBoolean
if true, the object will be locked even if it is on a layer that is locked or off.

Return Value

Type: Boolean
true if the object was successfully locked.
See Also