ObjectTablePurge Method (RhinoObject) |
Removes object from document and deletes the pointer. Typically you will
want to call Delete instead in order to keep the object on the undo list.
Namespace:
Rhino.DocObjects.Tables
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool Purge(
RhinoObject rhinoObject
)
Public Function Purge (
rhinoObject As RhinoObject
) As Boolean
Parameters
- rhinoObject
- Type: Rhino.DocObjectsRhinoObject
A Rhino object that will be deleted.
Return Value
Type:
Booleantrue if the object was purged; otherwise false.
See Also