Click or drag to resize

ObjectTablePurge Method (UInt32)

Removes object from document and deletes the pointer. Typically you will want to call Delete instead in order to keep the object on the undo list.

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool Purge(
	uint runtimeSerialNumber
)

Parameters

runtimeSerialNumber
Type: SystemUInt32
A runtime serial number of the object that will be deleted.

Return Value

Type: Boolean
true if the object was purged; otherwise false.
See Also