Click or drag to resize

ObjectTableAddLine Method (Point3d, Point3d, ObjectAttributes)

Adds a line object to Rhino.

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Guid AddLine(
	Point3d from,
	Point3d to,
	ObjectAttributes attributes
)

Parameters

from
Type: Rhino.GeometryPoint3d
The line origin.
to
Type: Rhino.GeometryPoint3d
The line end.
attributes
Type: Rhino.DocObjectsObjectAttributes
Attributes to apply to line.

Return Value

Type: Guid
A unique identifier for the object.
See Also