Click or drag to resize

ObjectTableAddRectangle Method (Rectangle3d, ObjectAttributes)

Adds a rectangle to the object table.

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public Guid AddRectangle(
	Rectangle3d rectangle,
	ObjectAttributes attributes
)

Parameters

rectangle
Type: Rhino.GeometryRectangle3d
The rectangle.
attributes
Type: Rhino.DocObjectsObjectAttributes
Attributes that will be linked with the surface object.

Return Value

Type: Guid
The ID.
See Also