Click or drag to resize

ObjectTableAddSurface Method (Surface, ObjectAttributes)

Adds a surface object to Rhino.

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Guid AddSurface(
	Surface surface,
	ObjectAttributes attributes
)

Parameters

surface
Type: Rhino.GeometrySurface
A duplicate of this surface is added to Rhino.
attributes
Type: Rhino.DocObjectsObjectAttributes
Attributes that will be linked with the surface object.

Return Value

Type: Guid
A unique identifier for the object.
See Also