Click or drag to resize

ObjectTableFindByUserString Method (String, String, Boolean, Boolean, Boolean, ObjectType)

Finds all objects whose UserString matches the search patterns.

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public RhinoObject[] FindByUserString(
	string key,
	string value,
	bool caseSensitive,
	bool searchGeometry,
	bool searchAttributes,
	ObjectType filter
)

Parameters

key
Type: SystemString
Search pattern for UserString keys (supported wildcards are: ? = any single character, * = any sequence of characters).
value
Type: SystemString
Search pattern for UserString values (supported wildcards are: ? = any single character, * = any sequence of characters).
caseSensitive
Type: SystemBoolean
If true, string comparison will be case sensitive.
searchGeometry
Type: SystemBoolean
If true, UserStrings attached to the geometry of an object will be searched.
searchAttributes
Type: SystemBoolean
If true, UserStrings attached to the attributes of an object will be searched.
filter
Type: Rhino.DocObjectsObjectType
Object type filter.

Return Value

Type: RhinoObject
An array of all objects whose UserString matches with the search patterns or null when no such objects could be found.
See Also