Click or drag to resize

ObjectType Enumeration

Defines binary mask values for each object type that can be found in a document.

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
[FlagsAttribute]
public enum ObjectType
Members
  Member nameValueDescription
None0 Nothing.
Point1 A point.
PointSet2 A point set or cloud.
Curve4 A curve.
Surface8 A surface.
Brep16 A brep.
Mesh32 A mesh.
Light256 A rendering light.
Annotation512 An annotation.
InstanceDefinition2048 A block definition.
InstanceReference4096 A block reference.
TextDot8192 A text dot.
Grip16384Selection filter value - not a real object type.
Detail32768 A detail.
Hatch65536 A hatch.
MorphControl131072 A morph control.
SubD262144 A SubD object.
BrepLoop524288 A brep loop.
BrepVertex1048576 a brep vertex.
PolysrfFilter2097152Selection filter value - not a real object type.
EdgeFilter4194304Selection filter value - not a real object type.
PolyedgeFilter8388608Selection filter value - not a real object type.
MeshVertex16777216 A mesh vertex.
MeshEdge33554432 A mesh edge.
MeshFace67108864 A mesh face.
Cage134217728 A cage.
Phantom268435456 A phantom object.
ClipPlane536870912 A clipping plane.
Extrusion1073741824 An extrusion.
AnyObject4294967295 All bits set.
See Also