Click or drag to resize

ConstructionPlane Class

Represents a construction plane inside the document.

Use Rhino.DocObjects.Tables.NamedConstructionPlaneTable methods and indexers to add and access a ConstructionPlane.

Inheritance Hierarchy
SystemObject
  Rhino.DocObjectsConstructionPlane

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class ConstructionPlane

The ConstructionPlane type exposes the following members.

Constructors
  NameDescription
Public methodConstructionPlane
Initializes a new instance of ConstructionPlane.
Top
Properties
  NameDescription
Public propertyDepthBuffered
Gets or sets whether the grid is drawn on top of geometry.

false=grid is always drawn behind 3d geometry

true=grid is drawn at its depth as a 3d plane and grid lines obscure things behind the grid.

Public propertyGridLineCount
Gets or sets the total amount of grid lines in each direction.
Public propertyGridSpacing
Gets or sets the distance between grid lines.
Public propertyGridXColor
Gets or sets the color of the grid X-axis mark.
Public propertyGridYColor
Gets or sets the color of the grid Y-axis mark.
Public propertyGridZColor
Gets or sets the color of the grid Z-axis mark.
Public propertyName
Gets or sets the name of the construction plane.
Public propertyPlane
Gets or sets the geometric plane to use for construction.
Public propertyShowAxes
Gets or sets whether the axes of the grid should be visible.
Public propertyShowGrid
Gets or sets whether the grid itself should be visible.
Public propertyShowZAxis
Gets or sets whether the Z axis of the grid should be visible.
Public propertySnapSpacing
when "grid snap" is enabled, the distance between snap points. Typically this is the same distance as grid spacing.
Public propertyThickLineColor
Gets or sets the color of the thicker, wider line.
Public propertyThickLineFrequency
Gets or sets the recurrence of a wider line on the grid.

0: No lines are thick, all are drawn thin.

1: All lines are thick.

2: Every other line is thick.

3: One line in three lines is thick (and two are thin).

4: ...

Public propertyThinLineColor
Gets or sets the color of the thinner, less prominent line.
Top
Methods
  NameDescription
Top
See Also