Click or drag to resize

ObjectMode Enumeration

Defines enumerated values for the display and behavior of single objects.

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public enum ObjectMode
Members
  Member nameValueDescription
Normal0Object mode comes from layer.
Hidden1Not visible, object cannot be selected or changed.
Locked2Visible, object cannot be selected or changed.
InstanceDefinitionObject3 Object is part of an InstanceDefinition. The InstanceDefinition m_object_uuid[] array will contain this object attribute's id.
See Also