Click or drag to resize

RhinoTransformObjectsEventArgs Class

EventArgs passed to RhinoDoc.BeforeTransform.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Rhino.DocObjectsRhinoTransformObjectsEventArgs

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class RhinoTransformObjectsEventArgs : EventArgs

The RhinoTransformObjectsEventArgs type exposes the following members.

Properties
  NameDescription
Public propertyGripCount
The number of Rhino object grips that will be transformed.
Public propertyGripOwnerCount
The number of Rhino object grip owners that will be changed when the grips are transformed.
Public propertyGripOwners
An array of Rhino object grip owners that will be changed when the grips are transformed. WARNING: these objects may be deleted at anytime after the event handler has been notified. Do not save references to these objects. Use the object's runtime serial number to safely reference these objects at a later time.
Public propertyGrips
An array of Rhino object grips that will be transformed. WARNING: these objects may be deleted at anytime after the event handler has been notified. Do not save references to these objects. Use the object's runtime serial number to safely reference these objects at a later time.
Public propertyObjectCount
The number of Rhino objects that will be transformed.
Public propertyObjects
An array of Rhino objects to be transformed. WARNING: these objects may be deleted at anytime after the event handler has been notified. Do not save references to these objects. Use the object's runtime serial number to safely reference these objects at a later time.
Public propertyObjectsWillBeCopied
True if the objects will be copied.
Public propertyTransform
The transformation to be applied.
Top
Methods
  NameDescription
Top
See Also