Click or drag to resize

Font Class

Defines a format for text.
Inheritance Hierarchy
SystemObject
  Rhino.DocObjectsFont

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public sealed class Font : ISerializable

The Font type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyBold
Public propertyDescription
Returns a long description that includes family, face, weight, stretch and style information. Generally not useful for finding matching fonts.
Public propertyEnglishFaceName
Returns English Face name
Public propertyEnglishFamilyName
Public propertyEnglishQuartetName
Public propertyFaceName
Returns Face name
Public propertyFamilyName
Public propertyFamilyPlusFaceName
Returns concatenated Family and Face names
Public propertyIsEngravingFont
Public propertyIsInstalled
Is this font installed on the system
Public propertyIsSimulated
Public propertyIsSingleStrokeFont
Public propertyIsSymbolFont
Public propertyItalic
Public propertyLogfontName
Returns Windows LOGFONT Face name
Public propertyPointSize
Public propertyPostScriptName
Returns the Font PostScriptName - "Apple font name"
Public propertyQuartetName
Public propertyRichTextFontName
Returns the Font RichTextFontName used in RTF strings: {\\fonttbl...{\\fN RichTextFontName;}...}
Public propertyStretch
Public propertyStrikeout
Public propertyStyle
Public propertyUnderlined
Public propertyWeight
Top
Methods
  NameDescription
Public methodStatic memberAvailableFontFaceNames
Public methodStatic memberFromQuartetProperties
Public methodGetObjectData
Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
Public methodGetSubstituteFont
If this font is not installed on the system, try to find a substitute
Public methodStatic memberInstalledFonts
Public methodStatic memberInstalledFonts(String)
Public methodStatic memberInstalledFontsAsQuartets
Top
See Also