Click or drag to resize

ReplayHistoryData Class

Provides history information to commands that will repeat history construction. Generally, a developer using this class will not construct a new instance, but receive one.
Inheritance Hierarchy
SystemObject
  Rhino.DocObjectsReplayHistoryData

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class ReplayHistoryData : IDisposable

The ReplayHistoryData type exposes the following members.

Properties
  NameDescription
Public propertyDocument
The document this record belongs to
Public propertyHistoryVersion
ReplayHistory overrides check the version number to ensure the information saved in the history record is compatible with the current implementation of ReplayHistory
Public propertyRecordId
Each history record has a unique id that Rhino assigns when it adds the history record to the history record table
Public propertyResults
Provides access to BOTH inputs and outputs of the replay history operation.

Use this property to then call an appropriate UpdateToX() method and make your custom history support work.

Top
Methods
  NameDescription
Public methodAppendHistoryResult
Create an empty history result and add it to the end of the Results array. Note that you should call Results again if you need them as the old Results array will be out of sync with this class.
Public methodDispose
Releases all resources used by the ReplayHistoryData
Public methodGetRhinoObjRef
In ReplayHistory, use GetRhinoObjRef to convert the information in a history record into the ObjRef that has up to date RhinoObject pointers
Public methodTryGetBool
Public methodTryGetColor
Public methodTryGetDouble
Public methodTryGetDoubles
Public methodTryGetGuid
Public methodTryGetGuids
Public methodTryGetInt
Public methodTryGetPoint3d
Public methodTryGetPoint3dOnObject
Public methodTryGetString
Public methodTryGetTransform
Public methodTryGetVector3d
Public methodUpdateResultArray
Update the Results array with a different set of values. Null entries in the newResults will result in empty ReplayHistoryResult elements
Top
See Also