Click or drag to resize

ReplayHistoryData Methods

The ReplayHistoryData type exposes the following members.

Methods
  NameDescription
Public methodAppendHistoryResult
Create an empty history result and add it to the end of the Results array. Note that you should call Results again if you need them as the old Results array will be out of sync with this class.
Public methodDispose
Public methodGetRhinoObjRef
In ReplayHistory, use GetRhinoObjRef to convert the information in a history record into the ObjRef that has up to date RhinoObject pointers
Public methodTryGetBool
Public methodTryGetColor
Public methodTryGetDouble
Public methodTryGetDoubles
Public methodTryGetGuid
Public methodTryGetGuids
Public methodTryGetInt
Public methodTryGetPoint3d
Public methodTryGetPoint3dOnObject
Public methodTryGetString
Public methodTryGetTransform
Public methodTryGetVector3d
Public methodUpdateResultArray
Update the Results array with a different set of values. Null entries in the newResults will result in empty ReplayHistoryResult elements
Top
See Also