Click or drag to resize

TextureType Enumeration

The TextureType controls how the pixels in the bitmap are interpreted.

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.6
Syntax
public enum TextureType
Members
  Member nameValueDescription
None0
Bitmap1 Deprecated - this should be diffuse
Diffuse1 The diffuse color of the material, ideally the albedo.
Bump2 bump map
Transparency3 Deprecated - see Opacity. This has always actually meant opacity in Rhino, so there is nothing to change.
Opacity3 value = alpha
Emap86 Emap/Environment texture
PBR_BaseColor1 Physically based materials only - base color. Re-uses diffuse texture slot.
PBR_Subsurface10 Physically based materials only - subsurface (greyscale)
PBR_SubsurfaceScattering11 Physically based materials only - subsurface scattering
PBR_SubsurfaceScatteringRadius12 Physically based materials only - subsurface scattering radius (greyscale)
PBR_Metallic13 Physically based materials only - metallic (greyscale)
PBR_Specular14 Physically based materials only - specular (greyscale)
PBR_SpecularTint15 Physically based materials only - specular tint (greyscale)
PBR_Roughness16 Physically based materials only - roughness (greyscale)
PBR_Anisotropic17 Physically based materials only - anisotropic (greyscale)
PBR_Anisotropic_Rotation18 Physically based materials only - anisotropic rotation 0 = 0, 255 = 360
PBR_Sheen19 Physically based materials only - sheen (greyscale)
PBR_SheenTint20 Physically based materials only - sheen tint (greyscale)
PBR_Clearcoat21 Physically based materials only - clearcoat (greyscale)
PBR_ClearcoatRoughness22 Physically based materials only - clearcoat roughness (greyscale)
PBR_OpacityIor23 Physically based materials only - ior (greyscale - remaps from 1.0 to 2.0)
PBR_OpacityRoughness24 Physically based materials only - transparency roughness (greyscale)
PBR_Emission25 Physically based materials only - emission (greyscale)
PBR_AmbientOcclusion26 Physically based materials only - occlusion (greyscale)
PBR_Displacement28 Physically based materials only - normal 8-bit RGB, alpha is ignored
PBR_ClearcoatBump29 Physically based materials only - clearcoat normal or bump (normal map, RGB)
PBR_Alpha30 Physically based materials only - clearcoat normal or bump (normal map, RGB)
See Also