Click or drag to resize

InstanceDefinition Class

This is the same as InstanceDefinitionGeometry, but in a Rhino document.
Inheritance Hierarchy

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class InstanceDefinition : InstanceDefinitionGeometry

The InstanceDefinition type exposes the following members.

Properties
  NameDescription
Public propertyArchiveFileStatus
Returns the archive file status of a linked instance definition.
Public propertyComponentType (Overrides InstanceDefinitionGeometryComponentType.)
Public propertyIndex
Index of this instance definition in the index definition table.
(Overrides ModelComponentIndex.)
Public propertyCode exampleIsDeleted
Returns true if this instance definition is deleted. Deleted object are not saved to a file archive.
(Overrides ModelComponentIsDeleted.)
Public propertyCode exampleIsReference
An object from a work session reference model is reference a reference object and cannot be modified. An object is a reference object if, and only if, it is on a reference layer.
(Overrides ModelComponentIsReference.)
Public propertyIsSystemComponent
True if this model component is a system constant.

An incomplete list of system constant model components is below:

  • ON_ModelComponent::Unset

  • ON_InstanceDefinition::Empty

  • ON_Linetype::Unset
  • ON_Linetype::Continuous
  • ON_Linetype::ByLayer
  • ON_Linetype::ByParent

  • ON_Layer::Unset
  • ON_Layer::Default

  • ON_TextStyle::Unset
  • ON_TextStyle::Default
  • ON_TextStyle::ByLayer
  • ON_TextStyle::ByParent

  • ON_DimStyle::Unset
  • ON_DimStyle::Default
  • ON_DimStyle::DefaultInchDecimal
  • ON_DimStyle::DefaultInchFractional
  • ON_DimStyle::DefaultFootInchArchitecture
  • ON_DimStyle::DefaultMillimeterSmall
  • ON_DimStyle::DefaultMillimeterLarge
Public propertyIsTenuous
True if this instance definition is from a linked file. It will be saved only if it is referenced by an instance reference object that is in the active geometry list and is being saved. Note that there can be multiple linked instance definitions with references to tenuous instance definitions.
Public propertyLayerStyle
Specifies how model components (layers, materials, dimension styles, etc.) from linked instance definition files appear in the active model.
Public propertyObjectCount
Number of objects this definition uses. This counts the objects that are used to define the geometry. This does NOT count the number of references to this instance definition.
Public propertySkipNestedLinkedDefinitions
This property applies when an instance definition is linked. If true, when reading the file that defines the content of the linked instance definition, skip any linked instance definitions found in that file. If false, when reading the file that defines the content of the linked instance definition, recursively load linked instance definitions found in that file.
Public propertySourceArchive
Gets the full file path for linked instance definitions.
Public propertyUnitSystem
Gets the unit system of the instance definition. If the instance definition was imported from another 3dm file, the unit system may differ from that of the document.
Public propertyUpdateType
Top
Methods
  NameDescription
Public methodCreatePreviewBitmap(DefinedViewportProjection, Size)
Creates a wireframe preview bitmap of the instance definition.
Public methodCreatePreviewBitmap(DefinedViewportProjection, DisplayMode, Size)
Creates a preview bitmap of the instance definition.
Public methodCreatePreviewBitmap(DefinedViewportProjection, Size, Boolean)
Creates a wireframe preview bitmap of the instance definition.
Public methodCreatePreviewBitmap(DefinedViewportProjection, DisplayMode, Size, Boolean)
Creates a preview bitmap of the instance definition.
Public methodCreatePreviewBitmap(Guid, DefinedViewportProjection, DisplayMode, Size, Boolean)
Creates a preview bitmap of the instance definition.
Public methodCreatePreviewBitmap(Guid, DefinedViewportProjection, IsometricCamera, Boolean, Size, Boolean)
Creates a preview bitmap of the instance definition.
Public methodEquals
Equality is checked against InstanceDefinition.Id
(Overrides ObjectEquals(Object).)
Public methodGetContainers
Gets a list of all the InstanceDefinitions that contain a reference this InstanceDefinition.
Public methodGetHashCode
Use Id.GetHashCode()
(Overrides ObjectGetHashCode.)
Public methodCode exampleGetObjects
Gets an array with the objects that belong to this instance definition.
Public methodGetReferences
Gets a list of the CRhinoInstanceObjects (inserts) that contains a reference this instance definition.
Public methodInUse
Determines whether the instance definition is referenced.
Public methodObject
returns an object used as part of this definition.
Public methodUseCount
Returns the number of references of this instance definition in the model. Both top-level references and nested instances are included in the count.
Public methodUseCount(Int32, Int32)
Returns the number of references of this instance definition in the model. Both top-level references and nested instances are included in the count.
Public methodUsesDefinition
Determines if this instance definition contains a reference to another instance definition.
Public methodUsesLayer
Returns true if some object in the instance definition is on the layer with the specified layer index.
Public methodUsesLinetype
Returns true if some object in the instance definition references the linetype with the specified linetype index.
Top
See Also