Click or drag to resize

InstanceDefinition Methods

The InstanceDefinition type exposes the following members.

Methods
  NameDescription
Public methodCreatePreviewBitmap(DefinedViewportProjection, Size)
Creates a wireframe preview bitmap of the instance definition.
Public methodCreatePreviewBitmap(DefinedViewportProjection, DisplayMode, Size)
Creates a preview bitmap of the instance definition.
Public methodCreatePreviewBitmap(DefinedViewportProjection, Size, Boolean)
Creates a wireframe preview bitmap of the instance definition.
Public methodCreatePreviewBitmap(DefinedViewportProjection, DisplayMode, Size, Boolean)
Creates a preview bitmap of the instance definition.
Public methodCreatePreviewBitmap(Guid, DefinedViewportProjection, DisplayMode, Size, Boolean)
Creates a preview bitmap of the instance definition.
Public methodCreatePreviewBitmap(Guid, DefinedViewportProjection, IsometricCamera, Boolean, Size, Boolean)
Creates a preview bitmap of the instance definition.
Public methodEquals
Equality is checked against InstanceDefinition.Id
(Overrides ObjectEquals(Object).)
Public methodGetContainers
Gets a list of all the InstanceDefinitions that contain a reference this InstanceDefinition.
Public methodGetHashCode
Use Id.GetHashCode()
(Overrides ObjectGetHashCode.)
Public methodCode exampleGetObjects
Gets an array with the objects that belong to this instance definition.
Public methodGetReferences
Gets a list of the CRhinoInstanceObjects (inserts) that contains a reference this instance definition.
Public methodInUse
Determines whether the instance definition is referenced.
Public methodObject
returns an object used as part of this definition.
Public methodUseCount
Returns the number of references of this instance definition in the model. Both top-level references and nested instances are included in the count.
Public methodUseCount(Int32, Int32)
Returns the number of references of this instance definition in the model. Both top-level references and nested instances are included in the count.
Public methodUsesDefinition
Determines if this instance definition contains a reference to another instance definition.
Public methodUsesLayer
Returns true if some object in the instance definition is on the layer with the specified layer index.
Public methodUsesLinetype
Returns true if some object in the instance definition references the linetype with the specified linetype index.
Top
See Also