Click or drag to resize

InstanceDefinitionUsesDefinition Method

Determines if this instance definition contains a reference to another instance definition.

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public int UsesDefinition(
	int otherIdefIndex
)

Parameters

otherIdefIndex
Type: SystemInt32
index of another instance definition.

Return Value

Type: Int32
0 no 1 other_idef_index is the index of this instance definition >1 This InstanceDefinition uses the instance definition and the returned value is the nesting depth.
See Also