Click or drag to resize

PhysicallyBasedMaterial Class

[Missing <summary> documentation for "T:Rhino.DocObjects.PhysicallyBasedMaterial"]

Inheritance Hierarchy
SystemObject
  Rhino.DocObjectsPhysicallyBasedMaterial

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class PhysicallyBasedMaterial

The PhysicallyBasedMaterial type exposes the following members.

Properties
Methods
  NameDescription
Public methodGetTexture
Get the texture that corresponds with the specified texture type for this material.
Public methodGetTextures
Get array of textures that this material uses
Public methodSetTexture
Set the texture that corresponds with the specified texture type for this material.
Public methodSynchronizeLegacyMaterial
Top
See Also