Click or drag to resize

FontFontOrigin Enumeration

Platform where font originated. This information is useful when searching for appropriate substitutes.

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public enum FontOrigin
Members
  Member nameValueDescription
Unset0 Not set.
Unknown1 Origin unknown. Changing an ON_Font characteristic like weight or style sets the origin to unknown.
WindowsFont2 Set from a Windows IDWriteFont by ON_Font::SetFromDWriteFont() or a Windows LOGFONT by ON_Font::SetFromWindowsLogFont() and FaceName and WindowLogfontName match a font installed on a Windows device.
AppleFont3 Set from an Apple CTFont. The PostScriptName() and FamilyName() match a font installed on device running MacOS or iOS. The FaceName() matches the "typeface" name shown in the MacOS FontBook app.
See Also