Click or drag to resize

ReplayHistoryResult Class

[Missing <summary> documentation for "T:Rhino.DocObjects.ReplayHistoryResult"]

Inheritance Hierarchy
SystemObject
  Rhino.DocObjectsReplayHistoryResult

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class ReplayHistoryResult

The ReplayHistoryResult type exposes the following members.

Properties
  NameDescription
Public propertyExistingObject
The previously existing object.

Do not attempt to edit this object. It might have been already deleted by, for example, dragging.

Top
Methods
  NameDescription
Public methodUpdateToAngularDimension
Public methodUpdateToArc
Public methodUpdateToBrep
Public methodUpdateToCircle
Public methodUpdateToClippingPlane(Plane, Double, Double, IEnumerableGuid, ObjectAttributes)
Public methodUpdateToClippingPlane(Plane, Double, Double, Guid, ObjectAttributes)
Public methodUpdateToCurve
Public methodUpdateToEllipse
Public methodUpdateToExtrusion
Public methodUpdateToHatch
Public methodUpdateToInstanceReferenceGeometry
Public methodUpdateToLeader
Public methodUpdateToLine
Public methodUpdateToLinearDimension
Public methodUpdateToMesh
Public methodUpdateToPoint
Public methodUpdateToPointCloud(IEnumerablePoint3d, ObjectAttributes)
Public methodUpdateToPointCloud(PointCloud, ObjectAttributes)
Public methodUpdateToPolyline
Public methodUpdateToRadialDimension
Public methodUpdateToSphere
Public methodUpdateToSubD
Public methodUpdateToSurface
Public methodUpdateToText(TextEntity, ObjectAttributes)
Public methodUpdateToText(String, Plane, Double, String, Boolean, Boolean, TextJustification, ObjectAttributes)
Public methodUpdateToTextDot
Top
See Also