Click or drag to resize

ConstructionPlaneGridDefaults Class

Default grid settings for a document
Inheritance Hierarchy
SystemObject
  Rhino.DocObjectsConstructionPlaneGridDefaults

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class ConstructionPlaneGridDefaults

The ConstructionPlaneGridDefaults type exposes the following members.

Constructors
  NameDescription
Public methodConstructionPlaneGridDefaults
Initializes a new instance of the ConstructionPlaneGridDefaults class
Top
Properties
  NameDescription
Public propertyGridLineCount
Number of grid lines in each direction
Public propertyGridSpacing
Distance between grid lines
Public propertyGridThickFrequency
This line frequency. 0: none, 1: all lines are thick, 2: every other is thick, ...
Public propertyShowGrid
Show the grid
Public propertyShowGridAxes
Show the grid axes
Public propertyShowWorldAxes
Show the world axes icon in the corner
Public propertySnapSpacing
When grid snap is enabled, the distance between snap points. Typically this is the same distance as grid spacing
Top
Methods
  NameDescription
Top
See Also