Click or drag to resize

AnimationProperties Class

Contains information used by the Animation Tools to create sun, season, turntable and fly through animations.
Inheritance Hierarchy
SystemObject
  Rhino.DocObjectsAnimationProperties

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class AnimationProperties : IDisposable

The AnimationProperties type exposes the following members.

Constructors
  NameDescription
Public methodAnimationProperties
Initializes a new instance of the AnimationProperties class.
Public methodAnimationProperties(AnimationProperties)
Initialize new instance of the AnimationProperties class.
Top
Properties
  NameDescription
Public propertyAnimationName
Gets or sets the name of the animation sequence.
Public propertyCameraPathId
Gets or sets the object ID of the camera path.
Public propertyCameraPoints
Gets or sets points of the camera path.
Public propertyCaptureMethod
Gets or sets the capture method of the animation which is either preview or full.
Public propertyCaptureType
Gets or sets the capture type of the animation.
Public propertyCurrentFrame
Gets or sets the current frame during animation record.
Public propertyDates
Gets or sets the dates that are calculated for seasonal/one day sun animations.
Public propertyDaysBetweenFrames
Gets or sets the days between captured frames for seasonal sun animation.
Public propertyDisplayMode
Gets or sets the ID of the view display mode (wireframe, shaded...).
Public propertyEndDay
Gets or sets the end day for seasonal day sun animation in the range 1 to 31.
Public propertyEndHour
Gets or sets the end hour for one day sun animation in the range 0 to 23.
Public propertyEndMinutes
Gets or sets the end minutes for one day sun animation in the range 0 to 59.
Public propertyEndMonth
Gets or sets the end month for seasonal day sun animation in the range 1 to 12.
Public propertyEndSeconds
Gets or sets the end seconds for one day sun animation in the range 0 to 59.
Public propertyEndYear
Gets or sets the end year for seasonal day sun animation in the range 1800 to 2199.
Public propertyFileExtension
Gets or sets the file extension of the saved frames created by the animation.
Public propertyFolderName
Gets or sets the location for the saved frames.
Public propertyFrameCount
Gets or sets the number of frames to be captured.
Public propertyHtmlFileName
Gets or sets the HTML file name.
Public propertyHtmlFullPath
Return HTML file path consisting of FolderName and HtmlFileName. To change this set FolderName and HtmlFileName.
Public propertyImages
Gets or sets the full path to the saved frames of an animation.
Public propertyLatitude
Gets or sets the latitude for sun animations in the range of -90 to +90.
Public propertyLightIndex
Internal value used while previewing animation.
Public propertyLongitude
Gets or sets the longitude for sun animations in the range of -180 to +180.
Public propertyMinutesBetweenFrames
Gets or sets the minutes between captured frames for one day sun animation.
Public propertyNorthAngle
Gets or sets the world angle corresponding to North in degrees. This angle is zero along the x-axis and increases anticlockwise.
Public propertyRenderFull
Gets or sets a value indicating whether to capture a frame in rendered mode.
Public propertyRenderPreview
Gets or sets a value indicating whether to capture a frame in preview rendered mode.
Public propertyStartDay
Gets or sets the start day for seasonal/one day sun animation in the range 1 to 31.
Public propertyStartHour
Gets or sets the start hour for seasonal/one day sun animation in the range 0 to 23.
Public propertyStartMinutes
Gets or sets the start minutes for seasonal/one day sun animation in the range 0 to 59.
Public propertyStartMonth
Gets or sets the start month for seasonal/one day sun animation in the range 1 to 12.
Public propertyStartSeconds
Gets or sets the start seconds for seasonal/one day sun animation in the range 0 to 59.
Public propertyStartYear
Gets or sets the start year for seasonal/one day sun animation in the range 1800 to 2199.
Public propertyTargetPathId
Gets or sets the object ID of the target path.
Public propertyTargetPoints
Gets or sets points of the target path.
Public propertyViewportName
Gets or sets the viewport that will be captured.
Top
Methods
  NameDescription
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Top
See Also