Click or drag to resize

EarthAnchorPoint Class

Contains information about the model's position in latitude, longitude, and elevation for GIS mapping applications.
Inheritance Hierarchy
SystemObject
  Rhino.DocObjectsEarthAnchorPoint

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class EarthAnchorPoint : IDisposable

The EarthAnchorPoint type exposes the following members.

Constructors
  NameDescription
Public methodEarthAnchorPoint
Initializes a new instance of the EarthAnchorPoint class.
Top
Properties
  NameDescription
Public propertyDescription
Gets or sets the long form of the identifying information about this location.
Public propertyEarthBasepointElevation
Gets or sets the point elevation on earth, in meters.
Public propertyEarthBasepointElevationCoordinateSystem
Gets or sets a value indicating the zero level convention relating to a location on Earth.
Public propertyEarthBasepointLatitude
Gets or sets a point latitude on earth, in degrees. +90 = north pole, 0 = equator, -90 = south pole.
Public propertyEarthBasepointLongitude
Gets or sets the point longitude on earth, in degrees.
Public propertyKMLOrientationHeadingAngleDegrees
Gets Keyhole Markup Language (KML) orientation heading angle in degrees.
Public propertyKMLOrientationHeadingAngleRadians
Gets Keyhole Markup Language (KML) orientation heading angle in degrees.
Public propertyKMLOrientationRollAngleDegrees
Gets Keyhole Markup Language (KML) orientation roll angle in degrees.
Public propertyKMLOrientationRollAngleRadians
Gets Keyhole Markup Language (KML) orientation roll angle in degrees.
Public propertyKMLOrientationTiltAngleDegrees
Gets Keyhole Markup Language (KML) orientation tilt angle in degrees.
Public propertyKMLOrientationTiltAngleRadians
Gets Keyhole Markup Language (KML) orientation tilt angle in degrees.
Public propertyModelBasePoint
Corresponding model point in model coordinates.
Public propertyModelEast
Earth directions in model coordinates.
Public propertyModelNorth
Earth directions in model coordinates.
Public propertyName
Gets or sets the short form of the identifying information about this location.
Top
Methods
  NameDescription
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Public methodEarthLocationIsSet
Checks if the earth location is set or not.
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodGetEarthAnchorPlane
Returns the earth anchor plane
Public methodGetModelCompass
Returns a plane in model coordinates whose X axis points East, Y axis points North and Z axis points Up. The origin is set to ModelBasepoint.
Public methodGetModelToEarthTransform
Gets a transformation from model coordinates to earth coordinates. This transformation assumes the model is small enough that the curvature of the earth can be ignored.
Public methodModelLocationIsSet
Checks if the model location is set or not.
Top
See Also