Click or drag to resize

EarthAnchorPoint Methods

The EarthAnchorPoint type exposes the following members.

Methods
  NameDescription
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Public methodEarthLocationIsSet
Checks if the earth location is set or not.
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodGetEarthAnchorPlane
Returns the earth anchor plane
Public methodGetModelCompass
Returns a plane in model coordinates whose X axis points East, Y axis points North and Z axis points Up. The origin is set to ModelBasepoint.
Public methodGetModelToEarthTransform
Gets a transformation from model coordinates to earth coordinates. This transformation assumes the model is small enough that the curvature of the earth can be ignored.
Public methodModelLocationIsSet
Checks if the model location is set or not.
Top
See Also