Click or drag to resize

HatchLine Class

Hatch lines are used by hatch pattern to specify the dashes and offset patterns of the lines.
Inheritance Hierarchy
SystemObject
  Rhino.DocObjectsHatchLine

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 8.0
Syntax
public class HatchLine : IDisposable

The HatchLine type exposes the following members.

Constructors
  NameDescription
Public methodHatchLine
Construts a new hatch line.
Public methodHatchLine(HatchLine)
Construts a new hatch line.
Top
Properties
  NameDescription
Public propertyAngle
Gets and sets the angle, in radians, of the hatch line. The angle is measured counter-clockwise from the x-axis.
Public propertyBasePoint
Get and sets this line's 2d base point.
Public propertyDashCount
Gets the number of dashes + gaps in this line.
Public propertyGetDashes
Gets all of the dashes.
Public propertyIsValid
Verifies a hatch line is valid.
Public propertyOffset
Get and sets this line's 2d offset for line repetitions. Offset.X is shift parallel to line. Offset.Y is spacing perpendicular to line.
Public propertyPatternLength
Get the total length of a pattern repeat.
Top
Methods
  NameDescription
Public methodAppendDash
Add a dash to the pattern.
Public methodDashAt
Get the dash length at the specified index.
Public methodDispose
Actively releases the unmanaged object.
Protected methodDispose(Boolean)
Releases the unmanaged object.
Protected methodFinalize
Passively releases the unmanaged object.
(Overrides ObjectFinalize.)
Public methodSetDashes
Sets a new dash array.
Top
Remarks
Each line has the following information: Angle is the direction of the line counter-clockwise from the x-axis. The first line origin is at the base point. Each line repetition is offset from the previous line. Offset.X is parallel to the line and Offset.Y is perpendicular to the line. The base and offset values are rotated by the line's angle to produce a location in the hatch pattern's coordinate system. There can be gaps and dashes specified for drawing the line. If there are no dashes, the line is solid. Negative length dashes are gaps. Positive length dashes are drawn as line segments.
See Also