Click or drag to resize

HatchLine Properties

The HatchLine type exposes the following members.

Properties
  NameDescription
Public propertyAngle
Gets and sets the angle, in radians, of the hatch line. The angle is measured counter-clockwise from the x-axis.
Public propertyBasePoint
Get and sets this line's 2d base point.
Public propertyDashCount
Gets the number of dashes + gaps in this line.
Public propertyGetDashes
Gets all of the dashes.
Public propertyIsValid
Verifies a hatch line is valid.
Public propertyOffset
Get and sets this line's 2d offset for line repetitions. Offset.X is shift parallel to line. Offset.Y is spacing perpendicular to line.
Public propertyPatternLength
Get the total length of a pattern repeat.
Top
See Also