Click or drag to resize

Worksession Class

Manages a list of models that are being used as reference geometry.
Inheritance Hierarchy
SystemObject
  Rhino.DocObjectsWorksession

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class Worksession

The Worksession type exposes the following members.

Properties
  NameDescription
Public propertyDocument
Gets the document that owns this worksession.
Public propertyFileName
Returns the path to the open worksession, or .rws, file. If there is no worksession file open, or the active worksession has not yet been saved, then null is returned.
Public propertyModelCount
Returns the number of models in the worksession. The active model will included in this count whether or not it has been saved.
Public propertyModelPaths
Returns the paths to the models used by the worksession. If the active model has not been saved, then it will not be included in the output array.
Public propertyRuntimeSerialNumber
Unique serial number for the worksession while the application is running. This is not a persistent value.
Top
Methods
  NameDescription
Public methodStatic memberFileNameFromRuntimeSerialNumber
Returns the path to the open worksession, or .rws, file. If there is no worksession file open, or the active worksession has not yet been saved, then null is returned.
Public methodModelPathFromSerialNumber
Returns the path to a model, used by the worksession, given a reference model serial number
Top
See Also