Click or drag to resize

MaterialRef Class

[Missing <summary> documentation for "T:Rhino.DocObjects.MaterialRef"]

Inheritance Hierarchy
SystemObject
  Rhino.DocObjectsMaterialRef

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class MaterialRef : IDisposable

The MaterialRef type exposes the following members.

Properties
  NameDescription
Public propertyBackFaceMaterialId
The Id of the Material used to render the back of an object.
Public propertyBackFaceMaterialIndex
The index of the material used to render the back of an object
Public propertyFrontFaceMaterialId
The Id of the Material used to render the front of an object.
Public propertyFrontFaceMaterialIndex
The index of the material used to render the front of an object
Public propertyMaterialSource
Determines if the simple material should come from the object or from it's layer.
Public propertyPlugInId
Identifies a rendering plug-in
Top
Methods
  NameDescription
Public methodDispose
Releases all resources used by the MaterialRef
Protected methodFinalize (Overrides ObjectFinalize.)
Top
See Also