ObjectTableSelect Method (ObjRef, Boolean, Boolean, Boolean) |
Select or deselects a single object.
Namespace:
Rhino.DocObjects.Tables
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool Select(
ObjRef objref,
bool select,
bool syncHighlight,
bool persistentSelect
)
Public Function Select (
objref As ObjRef,
select As Boolean,
syncHighlight As Boolean,
persistentSelect As Boolean
) As Boolean
Parameters
- objref
- Type: Rhino.DocObjectsObjRef
Object represented by this ObjRef is selected. - select
- Type: SystemBoolean
If true, the object will be selected, if false, it will be deselected. - syncHighlight
- Type: SystemBoolean
If true, then the object is highlighted if it is selected
and unhighlighted if is not selected.
- persistentSelect
- Type: SystemBoolean
Objects that are persistently selected stay selected when a command terminates.
Return Value
Type:
Booleantrue on success, false on failure.
See Also