Click or drag to resize

ObjectTableSelect Method (Guid, Boolean, Boolean, Boolean)

Select or deselects a single object.

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool Select(
	Guid objectId,
	bool select,
	bool syncHighlight,
	bool persistentSelect
)

Parameters

objectId
Type: SystemGuid
Id of object to select.
select
Type: SystemBoolean
If true, the object will be selected, if false, it will be deselected.
syncHighlight
Type: SystemBoolean
If true, then the object is highlighted if it is selected and unhighlighted if is not selected.
persistentSelect
Type: SystemBoolean
Objects that are persistently selected stay selected when a command terminates.

Return Value

Type: Boolean
true on success, false on failure.
See Also